Jump to content

Leaderboard

Popular Content

Showing content with the highest reputation on 05/25/2021 in all areas

  1. I can also confirm this, in Amazon EC2. But I only needed to change the Kamailio config. Correction; I also needed to add external/public ip to FreeSWITCH server at ext-rtp-ip, otherwise the sound didn't work. Br Tomas
    1 point
  2. Can confirm, applied these settings to a sandbox deployment without a bindable external IP and everything worked perfect.
    1 point
  3. You might find this link helpful. Although it's for AWS, the same config (at least mostly) would apply to Azure. https://github.com/OpenTelecom/kazoo-install-guide
    1 point
  4. The below works in AWS. I haven't worked much with Azure's networking environment, but I can't imagine (well, I can, it's Microsoft) that the DNAT / SNAT workings are too different. Assign PUB IP to instance/interface, then just change the below configs in Kamailio and Freeswitch. If you're using an all-in-one, then you'll just need one PUB. I've got a clustered setup going with my Kama and FS instances separate. On Freeswitch - Remember FS trunks directly out of the cluster. It does not route out back through Kamailio. nano /etc/kazoo/freeswitch/sip_profiles/sipinterface_1.xml Set <param name="ext-rtp-ip" value="auto"/> to <param name="ext-rtp-ip" value="x.x.x.x."/> (x.x.x.x is the external IP you have assigned to this instance) Set <param name="local-network-acl" value="localnet.auto"/> to <param name="local-network-acl" value="NOPE"/> # “NOPE” doesn't matter, just not localnet.auto On Kamailio nano /etc/kazoo/kamailio/local.cfg Should be down at the bottom of the file. The advertise flag essentially tells Kamailio what to change the IP to when it detects NAT. listen=UDP_SIP advertise x.x.x.x:5060 listen=TCP_SIP advertise x.x.x.x:5060 (where x.x.x.x is your public IP address you assigned) I believe that's it. Hopefully that'll help.
    1 point
×
×
  • Create New...