Jump to content

80tech

Members
  • Posts

    10
  • Joined

  • Last visited

  • Days Won

    1

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi everyone, I recently have an issue about early media in kazoo 4.3. When I make an outbound call, my carrier will respond a 180 with SDP to the kazoo. In this case, the FreeSwitch doesn't forward RTP packets sent by the carrier to the extension. Instead of forwarding RTP packets, FreeSwitch will generate RTP packets of ringback tone by itself. Any idea how I can make FS forward early media? Thanks Tommy
  2. @rhys Hi Rhys, Did you find any solution to your problem? Tommy
  3. @RuhNet Thank you for your detailed suggestion, which is really helpful.
  4. Hi all, I am using kazoo 4.3. The carrier I am using needs registration for each client. I implemented it by setting the config of FreeSWITCH. It works well when I use a FreeSWITCH server. The problem appears in cluster mode. If there are over 2 FreeSWITCH servers, for redundancy, I need to have each FreeSwitch registered with the same configuration. Each FreeSwitch server will register with the same accounts. But the carrier only allows one terminal to register at the same time. Is there any better solution for this case in cluster mode? Thanks Tommy
  5. Hi louyingge, I got the same question, and tried to use the limit feature of the account app, but it doesn't work. Have you figured out a way of limiting that? Thanks Tommy
  6. Hi all, Thanks for all the answers, much appreciated. It finally worked by referring to Meat's detailed information. Here is my configuration. On Freeswitch vi /etc/kazoo/freeswitch/sip_profiles/sipinterface_1.xml <param name="ext-rtp-ip" value="x.x.x.x"/> ##x.x.x.x is the external IP address you have assigned to this instance <param name="local-network-acl" value="NOPE"/> ##this is the setting I hadn't configured before, so the RTP routing had problems. systemctl restart kazoo-freeswitch On Kamailio vi /etc/kazoo/kamailio/local.cfg listen=udp:a.a.a.a:5060 advertise x.x.x.x:5060 ##a.a.a.a is your private IP address x.x.x.x is the external IP address systemctl restart kazoo-kamailio Thanks Tommy
  7. Hi everyone! I have set a KAZOO server behind NAT. The problem is that Kamailio fills the private IP address in SIP messages. By modifying some parameters of Kamailio, SIP signaling transmission works well, but RTP forwarding still has problems. Does anyone know how to configure SDP to use a public IP address? Any guidance would be appreciated. Tommy
×
×
  • Create New...