Jump to content

How To Blacklist Privacy Calls


extremerotary
 Share

Recommended Posts

Hey guys,

I have many customers who want to block anonymous calls. Using the blacklist, I can block specific numbers, including +0000000000. However, if an INVITE comes in with 

From: "Anonymous" <sip:Restricted@IP_ADDRESS>;tag=gK081f67ae
and
Privacy: id

It looks like kazoo does not evaluate it against the blacklist. I don't even see a log line for "not blacklisted". Stepswitch_inbound "runs routines" for the dialed number, but nothing about checking the blacklist. Is there a way to blacklist these types of anonymous calls?

Link to comment
Share on other sites

This is already addressed in 4.1. There is now a blacklist of private numbers flag, and it will block them with a smarter routine that checks the headers without you having to specify the numbers like before.

 

Check  https://github.com/2600hz/kazoo/blob/master/applications/crossbar/doc/blacklists.md- it's listed as "should_block_anonymous"

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...