Jump to content

SRTP on Hosted Platform


Recommended Posts


I have a specific client interested in using SRTP to encrypt voice calls.  I am trying to test these features out but I am running into some issues.  Here is what I have done so far on my Yealink T46S.

1. Edited device in advanced call flows.  Under the Audio tab I set Secure RTP to SRTP.  This erases your advanced provisioner profile for the device. :(

2. In the Advanced Provisioner under Lines I made sure that RTP Encryption (SRTP) was set to Enabled.

3. In the Advanced Provisioner under Lines I made sure that the Primary Address was set to secure-us-east.p.zswitch.net.

4. In the phones web interface under Account -> Advanced I manually set RTP Encryption (SRTP) to "Compulsory".  I was not able to place outbound calls without setting this manually.


I am able to place outbound calls and lock shows up on my Yealink phone indicating that the call is encrypted.  However, I am seeing some major issues and I was hoping to get some assistance.

1. BLF is not working.  The BLF keys are showing a RED X.

2. I am not able to receive inbound calls.  The Hangup Cause is "RECOVERY_ON_TIMER_EXPIRE" with a hangup code of "sip:408"


Any suggestions on how I could get this working?  

Link to comment
Share on other sites

  • 1 month later...
  • 8 months later...
On 3/13/2018 at 11:26 AM, Logicwrath said:

Anything new on this?  It would be great if there was a guide for setting this up properly on the hosted platform.

IT works for me :D 

Using Advanced Call Flows - Device - Audio - Secure RTP  (Select SRTP)




Then in Advanced Provisioner for the Device 

Config - Lines - Scroll to the Bottom of " 1 " In Advanced - Make sure the RTP Encruption (SRTP) is enabled. 



Restart the phone (if you made a change versus building new) 

From what I can tell. That is all now, as of Version 4.3-11

The only thing different I can tell, is that there is a "Lock" on the Yealink phones, AFTER the call is established. 

Link to comment
Share on other sites

  • Create New...