Jump to content
KAZOOcon: hackathon signup and details here! ×

Extension as outbound caller id


Sebacius

Recommended Posts

Hey guys, i have a special situation with our PBX. 

Since we are moving from cisco to kazoo we decided to create a trunk between them to facilitate the transition and basically they call eachother prepending digits to the extension, so that if you want to call a number in cisco, we created the user in kazoo and put a callforward to 88XXXX and then a resource that would take hat 88XXX and send it to call manager. 

Everything is working great, however when calling from kazoo->cisco , kazoo will put the external DID mask for the caller id or the external mask for the account . 

 

Is it possible to tell kazoo to send the Extension number in the caller id when sending calls to this resource? 

 

Link to comment
Share on other sites

I tried updating the resource but its still sending the main number as caller id . Do i need to update or refresh or reload something? 

    "data": {
        "rules": [
            "^88(\\d{4})$"
        ],
        "name": "Call Manager",
        "gateways": [
            {
                "realm": "10.101.10.11",
                "server": "10.101.10.11",
                "enabled": true,
                "channel_selection": "ascending",
                "custom_sip_headers": {},
                "endpoint_type": "sip",
                "force_port": false,
                "invite_format": "route",
                "port": 5060,
                "skype_rr": true,
                "caller_id_type": "internal"
            }
        ],
        "emergency": false,
        "enabled": true,
        "flags": [],
        "grace_period": 5,
        "media": {
            "audio": {
                "codecs": [
                    "PCMU"
                ]
            },
            "video": {
                "codecs": []
            }
        },

Link to comment
Share on other sites

×
×
  • Create New...